Plesk upgrade from PHP 5.1 to latest

Its quite simple actually – but I had to google for ages trying to find the answer.

wget -q -O - http://www.atomicorp.com/installers/atomic.sh | sh
yum upgrade php* mysql*

Bear in mind this will do a server upgrade – but seeing as this is a webserver, its probably best to have the latest versions for everything in terms of less security vulnerabilities.

EDIT> More things I needed to document. Incresing the amount of IMAP connections allowed as Thunderbird was erroring out.

perl -p -i -e 's/^MAXDAEMONS=40/MAXDAEMONS=80/g' /etc/courier-imap/imapd
perl -p -i -e 's/^MAXPERIP=4/MAXPERIP=40/g' /etc/courier-imap/imapd
/etc/init.d/courier-imap stop
/etc/init.d/courier-imap start

Comments